テーマ更新でエラー-Twenty Ten-・・・解決

2021/07/23

何だかよくわからないけど、よく見るとTwentyTenのバージョン3.3から

3.4では、ファイルが一つ増えてる。

この追加されたファイルを子テーマにコピーすれば解決!

ファイルの比較は、以下。

追加されたのは、「block-patterns.php」これを子テーマの直下にコピーしたら、無事、エラーを回避できました。

エラー状況は、以下の文面ですが、

Warning: require(省略・・・/子テーマ名/block-patterns.php): failed to open stream: No such file or directory in 省略\wp-content\themes\twentyten\functions.php on line 743

とあるけど、子テーマの中に「block-patterns.php」というのは、無いのでバージョン別のファイルを比較すると、、、

なんだ?追加されたもの?

ということで、子テーマにファイルをコピーしてみた。

これが、正解かどうかは不明だけど、、、

【このテスト時のシステム状況】

一端、ローカルPCでテスト:XAMPを使用

サーバー:さくらインターネット

WordPressバージョン:5.8(この時点で最新バージョン)

【追記】

TwentyTenの3.3から3.4に更新する前に、まず、3.4のバージョンをダウンロードして、追加されたファイル(block-patterns.php)を子テーマにコピーしておくと、エラーも何もなく更新できる。

エラーを確認して、子テーマにこのファイルをコピーしてもエラーはなくなるけど。その他子テーマの構成などが違うこともあるかもしれませんので、あくまで自己責任、ということでご参考まで、。